Monthly Archives: December 2013

Kuukausien lukumäärä

Kuinka monta kuukautta on kahden päivämäärän välillä?

Ohessa kaava, joka laskee täysien kuukausien lukumäärän (lukumäärä siis pyöristetään alaspäin).

Huomaa, että tulossolu on muotoiltava numeroksi tai muotoon yleinen.

=JOS(PÄIVÄ(B1)>=PÄIVÄ(A1);0;-1)+(VUOSI(B1)-VUOSI(A1))*12+KUUKAUSI((B1)-KUUKAUSI(A1))

=IF(DAY(B1)>=DAY(A1);0;-1)+(YEAR(B1)-YEAR(A1)) *12+MONTH(B1)-MONTH(A1)

Excelissä on myös piilotettu funktio PVMERO, (DATEDIF) jota voi käyttää.

Syntaksi: PVMERO(ens_pvm;viim_pvm;yksikkö)

Yksikkö:

y – kokonaisien vuosien määrä

m – kokonaisten kuukausien määrä

d – päivien määrä

md – Ens_pvm:n ja viim_pvm:n välisten kuukausien määrä. Päivämäärien päivillä ja vuosiluvuilla ei ole merkitystä

yd – Ens_pvm:n ja viim_pvm:n välisten päivien määrä. Päivämäärien vuosiluvuilla ei ole merkitystä.

Esim. joka palauttaa kahden päivämäärän välisen kuukausien määrän:

=PVMERO(A2;B2;”m”)

Office 2013 kaatuilee

Office 2013 (Word, Excel, PowerPoint) ei käynnisty kunnolla, vaan kaatuu saman tien. Tämän kaatumisen voi aiheuttaa esimerkiksi apuohjelma, joka ei ole yhteensopiva kyseisen Office-ohjelmaversion kanssa.

Käynnistä tällöin ohjelma vikasietotilassa kirjoittamalla komentoriville

    winword /safe

tai

    excel /safe

(Windows 72:ssa: Käynnistä ja hakukenttään winword /safe).

Siirry tämän jälkeen asetuksiin, Tiedosto/Asetukset ja Lisäohjelmat (File/Options, Add-Ins).

Poista lisäohjelmat ja kokeile ohjelman käynnistämistä uudestaan.