Nopeampi PHAKU

Tee Excel PHAKU (VLOOKUP) kaavastasi hieman nopeampi parilla pikku kikalla.

Ensiksi älä käytä & -merkkiä yhdistäessäsi hakuehtoa. Luo oma sarake yhdistelylle ja viittaa hakukaavassa siihen.

Siis älä tee näin =PHAKU(A2&B2;Tauli2!$A$1:$C$1000;2;EPÄTOSI)

Luo oma sarake yhdistelylle: =A2&B2 ja viittaa tähän sarakkeeseen PHAKU -kaavassa.

 

Toinen nopeuttava tekijä on; lajittele ensin taulukko josta haet tietoa (hakusarakkeen mukaan).

 

Kolmas mihin usein törmää on JOS -lausekkeen käyttö PHAKU -kaavassa kun halutaan virhearvo pois. Käytä JOSVIRHE -funktiota tällaisissa tilanteissa.

=JOSVIRHE(PHAKU(A2&B2;Tauli2!$A$1:$C$1000;2;EPÄTOSI);” “). Tämä esimerkkikaava jättää solun tyhjäksi jos hakuarvoa ei löydy.

 

Leave a Reply

Your email address will not be published. Required fields are marked *