Tag Archives: format as table

Yksi syy lisää käyttää taulukoita Excelissä

Excelin taulukot ovat paljon paljon muuta kun listojen kaunis väritys.

Kun olet määritellyt listan taulukoksi (Table) saat taulukkotyökalut käyttöösi. Niistä löydät mm osittajan suodattamista varten ja summarivin joka näyttää suodatun summat, keskiarvot jne.

Taulukko laajenee automaattisesti kun lisäät rivejä ja sarakkeita joka taas helpottaa pivot-raporttien hallintaa.

Mutta saat paljon muutakin.

Ensiksi nimeä taulukko. Teet sen taulukkotyökalun valintanauhasta, ylä vasemmalla on taulukon nimiruutu. Kirjoita siihen joku kuvaava nimi ilman välilyöntejä ja erikoismerkkejä, esim. Myynti, Varasto tai muuta vastaavaa.

Nyt voi siirtyä mihin tahansa työkirjan laskentatauluun ja kirjoittaa kaavan jossa viittaat luotuun tauluun ja sen sarakkeisiin.

Esim.: =SUMMA(TaulukoNimi[SarakkeenNimi]. Excel jopa ehdottaa sinulle sarakkeiden nimiä samalla tavalla, kun funktion argumentteja.
Kaavojen kirjoittaminen yksinkertaistuu, ei enää hankalia hiirellä alueiden maalaamisia!

Taulun käyttö indeksin ja vastineen kanssa: =INDEX(Sales[Ship Country];MATCH(A1;Sales[Order ID];0))

ja PHAKU -funktion kanssa: =VLOOKUP(A1;Sales[#All];3;FALSE)