Tag Archives: matriisikaava

Matriisikaavoja

Joissakin tilanteissa matriisikaava voi olla paras mahdollinen tapa luoda kaava ja joissakin tapauksissa jopa ainoa tapa. Jotkut Excelin funktiot vaativat myös matriisikaavaa toimiakseen.

Matriisikaava syötetään aina näppäinyhdistelmällä Ctrl+Vaihto+Enter, (Ctrl-Shift+Enter).
Jos laitat matriisikaavan solualueelle, et voi muokata yksittäistä kaavasolua, vaan koko matriisikaava on muokattava. Valitset sen alueen, jossa matriisikaava on ja sitten muokkaat sitä.

Kaikessa yksinkertaisuudessaan se on alue, jonka kaikkia elementtejä kerrotaan samalla arvolla, esim.:

 

Esimerkissä kerrotaan alueen A1:B2 arvot solun A4 arvolla ja tulos laitetaan alueelle A6:B7.
Kaikissa alueen A6:B7 soluissa on sama kaava {=A1:B2*A4}.
Teet laskennan seuraavasti:
Valitse tulosalue (A6:B7)
Kirjoita kaava =A1:B2*A4
Vahvista kaava painamalla Ctrl+Vaihto+Enter, tämä on matriisikaavan syöttötapa.
Excel lisää kaavan ympärille aaltosulut, { }.

Toinen esimerkki

 

Laskelma, joka palauttaa virheitä, mutta haluat summata tulokset virheistä huolimatta.
Esimerkiksi seuraava laskelma:
Sarakkeessa A on arvoja, joita jaetaan sarakkeen B arvoilla.
Jos sarakkeessa B on nolla (0) tai tyhjä, saadaan virhe ja summaus ei tule onnistumaan (solussa C5 on normaali summakaava).
Mutta jos summakaava laitetaan seuraavasti {=SUMMA(JOSVIRHE(C1:C3;””))} saadaan oikea vastaus {=SUMM(IFERROR(C1:C3;””))}. Tämän kaavan tulos on solussa C6.

 

Kolmas esimerkki

 

Lasketaan sarakkeen B ja C muutoksen keskiarvo suoraan soluun B7 ilman että ensin laskettaisiin erotukset D sarakkeeseen ja sitten D sarakkeen keskiarvo.

 

Kaava on matriisikaava muotoa {=KESKIARVO(B2:B5-C2:C5)}
{=AVERAGE(B2:B5-C2:C5)}
Kaava laskee solujen B ja C:n erotuksen ja sen jälkeen keskiarvon erotuksista.

Neljäs esimerkki

 

Lasketaan kuinka monta solua alueella B2:D5 on tekstiä.

 

Tällöin kirjoitetaan seuraavanlainen kaava joka on matriisimuodossa:
{=SUMMA(ONTEKSTI(B2:D6)*1)}
{=SUM(ISTEXT(B2:D6)*1)}
Funktio ONTEKSTI palauttaa TOSI jos solussa on tekstiä ja TOSI * 1 on 1, joten kun ykköset summataan saadaan tekstisolujen määrä.

 

Viides esimerkki

 

Lasketaan SUUNTAUS (TREND) soluihin B5:B7 perustuen arvoihin B2:B4.
Funktio palauttaa matriisin, joten se on kirjoitettava matriisikaavana.
Kun kirjoitat kaavan, valitse ensin alue, johon haluat tuloksen (B5:B7).

 

Kuudes esimerkki

 

Kun käytetään Excelin toimintoa Arvotaulukko, luo toiminto tulossoluihin matriisikaavan.

 

 

Esimerkissä lasketaan tuleva arvo eri vuosille ja eri korkoprosenteilla, jos sijoitetaan 500 € kerran kuukaudessa.

Solun B7 kaava on: =TULEVA.ARVO(B1/12;B2;B3) ja se luodaan ensimmäiseksi (FV).
Tämän jälkeen kirjoitetaan maksuerät soluihin C7:I7 (itse olen kirjoittanut vuodet C6:I6 ja laittanut kaavan C7:I7 joka on =12*C6, =12*D6… jne.
Sitten valitsen alueen B7:I12 ja toiminnon Arvotaulukko kohdasta Entä jos analyysi Tiedot valintanauhasta (Data, What-If Analysis, Data Table) .
Rivin syöttösoluksi (Row input cell) valitsen B2, jossa minulla on maksuerät, ja sarakkeen syöttösoluksi (Column input cell) B1, jossa minulla on korkoprosentti.

 

Taulukko näyttää minulle tulevan arvon eri vuosille eri korkoprosenteilla.

Summan laskeminen ei onnistu

Kun summan laskeminen ei onnistu sen takia kun alueella on virhearvoja niin tällöin voidaan käyttää matriisikaavaa ja JOSVIRHE (ISERROR) funktiota.

Esimerkki:

Sarakkeissa A ja B on arvoja. A-sarakkeen arvot jaetaan B sarakkeiden arvoilla jolloin saadaan C sarakkeeseen virhearvo jos B:ssä on nolla (0) tai on tyhjä.

Tällöin kuten esimerkissä näkyy saadaan myös virhe soluun C5 jossa yritetään summata C-sarakkeen arvoja. Jotta summa voitaisiin laskea C:n virhearvoista huolimatta käytetään matriisikaavaa kaavaa ja funktiota JOSVIRHE (IFERROR) summakaavassa:
{=SUMMA(JOSVIRHE(C1:C4;””))}
{=SUM(IFERROR(C1:C4;””))}

Kaava kirjoitetaan normaalisti mutta enterin sijaista painetaan Ctrl+Vaihto+Enter jolloin saadaan aikaan matriisikaava.

Esimerkin D-sarakkeessa on käytetyt kaavat.

Esimerkki

Esimerkki