Tag Archives: päivämäärämuotoilu

Päivämäärämuotoiluja

Voit muotoilla päivämääriä monella eri tavalla Excelissä.
Löydät muotoilut esimerkiksi painamalla Ctrl+1 (Muotoile solut).
Siirry avautuvassa valintaikkunassa Luku-välilehdelle ja valitse Luokka Oma.
(Valmiita päivämäärämuotoiluja löytyy myös kohdasta Päivämäärä.)
Jos valittuna on solu, jossa sinulla on päivämäärä, näet esimerkin kohdassa Malli.
Laji-kohtaan voit määritellä esitysmuodon.
Alla olevassa kuvassa on esimerkkejä muotoilukoodeista, rivillä 3 ja rivillä 4 koodin esitysmuoto.
p = päivä, k = kuukausi, v = vuosi.
Englanninkielisissä asetuksissa D = Date, M = Month, Y = Year

Päivämäärämuotoiluja

Päivämäärämuotoiluja

Kalenteri

Seuraavassa esimerkissä on luotu Excelissä kalenteri. Siinä hyödynnetään päivämäärämuotoilua, ehdollista muotoilua (Conditional Formatting) ja funktioita VIIKONPÄIVÄ (WEEKDAY), VIIKKO.NRO (WEEKNUM) ja JOS (IF).

Kalenteri

Kalenteri

Soluun A3 on kirjoitettu aloituspäivä, joka on muotoiltu muotoon pp.kk.vv
Solussa A4 on kaava =A3+1 (lisätään yksi päivä edelliseen päivämäärään, muotoiltu pp.kk.vv).
Solussa A4 kaava on kopioitu niin pitkälle alas kun päivämääriä halutaan.
Soluun B3 on laitettu kaava =A3 ja kopioitu alas. Muotoilu on ppp.
Soluun C3 on laitettu kaava =JOS(VIIKONPÄIVÄ(A3;2)=1;VIIKKO.NRO(A3;2);””) joka tutkii mikä viikonpäivä on kyseessä. Jos se on maanantai, viikkonumero kirjoitetaan soluun, muussa tapauksessa ei mitään.

VIIKONPÄIVÄ-funktio palauttaa päivän järjestysnumeron ja argumentilla 2 kerrotaan että viikko alkaa maanantaista. Eli jos funktio palauttaa 1, niin kyse on maanantaista ja tällöin kirjoitetaan soluun viikon numero.

VIIKKO.NRO-funktion argumentit ovat mistä päivästä lasketaan viikkonumero ja miten vuoden ensimmäinen viikko käsitellään.

Tämän jälkeen on valittu koko alue, esimerkissä kohdasta A3 aina kalenterin loppuun D302 ja valittu
Aloitus – Ehdollinen muotoilu, Uusi sääntö (Home – Conditional Formatting, New Rule).

Valintaikkunasta valitaan Määritä kaavan avulla, mitkä solut muotoillaan (Use a formula to determine which cells to format).

Kirjoitetaan kaava =VIIKONPÄIVÄ($A3;2)>5 kohtaan Muotoile arvot, joissa tämä kaava on tosi: (Format values where this formula is true:)
ja valitaan haluttu muotoilu kohdasta Muotoile (Format).

Huomaa kaavan lukitus! Sarake A lukitaan, koska päivä määritellään sarakkeen A:n mukaan.

Lopuksi napsautetaan OK:ta, jotta päästään takaisin laskentatauluun.