Tag Archives: viittaukset

Solujen viittaukset

Kun kaavaa kopioidaan on viittaustavoilla merkitystä.

Yleensä kaavoissa on suhteelliset viittaukset (A1, B1 jne.), eli solujen osoitteet muuttuvat sitä mukaan kun kaavaa kopioidaan ja viittaukset pysyvät samassa suhteessa soluun jossa on kaava.

Heti kun lähdetään laskemaan esim. prosenttiosuuksia tai muuttamaan jotakin lukua kertoimella joka on aina samassa solussa, ja kaavaa halutaan kopioida, tulee eteen tarve muuttaa viittaustapaa esim. suoraksi ($A$1, $B$1 jne.).

Tämä muutos tehdään kätevämmin painamalla funktionäppäintä F4.

Eli kun kaavaa kirjoitetaan ja osoitin vilkkuu viittauksen perässä painetaan F4 viittaustavan muuttamiseksi. Kun painetaan toistuvasti F4:sta Excel muuttaa joka kerta viittaustapaa:

Ensimmäisen kerran F4:sta -> $A$1 (lukitaan koko solu)
Toisen kerran -> A$1 (lukitaan rivi)
Kolmannen kerran -> $A1 (lukitaan sarake)
Neljännen kerran -> A1 (suhteellinen)

Jos kaava on jo valmiina voit asettaa osoittimen sen viittauksen sisään tai heti perään jonka viittaustapaa haluat muuttaa ja painaa F4:sta.

Jos on useampi viittaus kaavassa, esim. alue jonka haluat “lukita” voit valita ne viittaukset kaavassa (maalata) ja sitten painaa F4:sta.

Esim.:

A

B

C

D

E

F

1

Sar 1

Sar 2

Yhteensä
Alue

Yhteensä yksittäiset solut

% osuus totaalista

2

Nimike 1

10

20

=SUMMA(B2:C2)

=B2+C2

=E2/$E$4*100

3

Nimike 2

15

25

40

40

57,14

4

Totaali

25

45

70

70

100,00

 

Kaavat sarakkeissa D, E ja F voidaan kopioida alas. Sarakkeessa F solu E4 on lukittu koska se on yhteinen kaikille kaavoilla asianomaisessa sarakkeessa. Jos viittausta ei lukittaisi jouduttaisiin kaava kirjoittamaan uusiksi joka riville.

Sarakkeiden D ja E kaavat eivät ole lukittuja koska siinä viittaus on aina muututtava vastaamaan asianomaista riviä, eli kaavasolua nähden viitataan aina samalla tavalla.